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Contact:  
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Support: support@sightlineapplications. com  

Phone: +1 (541) 716-5137 

Export Controls 

Exports of SightLine products are governed by the US Department of Commerce, Export Administration 
Regulations (EAR); classification is ECCN 4A994. The export summary sheet located on the 
support/documentation page of our website outlines customers responsibilities and applicable rules. 
SightLine Applications takes export controls seriously and works to stay compliant with all export rules. 

Copyright and Use Agreement  

© Copyright 2018, SightLine Applications, Inc. All Rights reserved. The SightLine Applications name and 
logo and all related product and service names, design marks and slogans are the trademarks, and 
service marks of SightLine Applications, Inc.  

Before loading, downloading, installing, upgrading or using any Licensed Product of SightLine 

Applications, Inc., users must read and agree to the license terms and conditions outlined in the End 

User License Agreement. 

All data, specifications, and information contained in this publication are based on information that we 

believe is reliable at the time of printing. SightLine Applications, Inc. reserves the right to make changes 

without prior notice.  

Alerts 

The following notifications are used throughout the document to help identify important safety and 
setup information to the user: 

 CAUTION: Alerts to a potential hazard that may result in personal injury, or an unsafe practice 
that causes damage to the equipment if not avoided. 

 

 IMPORTANT: Identifies crucial information that is important to setup and configuration 

procedures. 

 Used to emphasize points or reminds the user of something. Supplementary information that aids in 
the use or understanding of the equipment or subject that is not critical to system use. 
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1 Overview 

This document outlines the steps for managing the following system files using the SightLine upgrade 
utility application, or command line versions of the SightLine upgrade utilities that can be managed 
from a customer GUI implementation (see the Command Line File Management section). 

• Firmware:  The video processing software and support items that are loaded on the OEM video 
processor.  

• Parameter File:  A file on the video processor which contains all the unit’s non-volatile settings.  

• License File:  A file on the video processor (linked to the HW serial number for the device) that 
contains the enable application bits for that unit (functions that are enabled).  

• Program Files: Used for getting and placing custom Lua scripts and DLLs.  

• Splash Screen: If the splash JPEG file is present on the unit it will be displayed at startup. It will 
continue to display until a SightLine command is received by the unit. Connecting to the unit with 
Panel Plus sends the Get Version Number (0x00) message and will disable the splash screen. If the 
default camera is not connected, a No Video Source Available message will be displayed instead of 
the splash screen.  

• User Logo:  SightLine supports placement of a customer logo watermark file on the video for 
branding purposes. The file is kept in the unit’s memory.  

1.1 MicroSD Card Recovery 

This document contains steps updating the firmware from a microSD card. This process is useful for 
recovering a board that is either not working as designed or is not communicating. See the Appendix 
for more information.  

1.2 Associated Documents 

EAN-Startup Guide 1500-OEM: Describes steps for connecting, configuring, and testing the 1500-OEM 
video processing board on the 1500-AB accessory board.  

EAN-Startup Guide 3000-OEM: Describes steps for connecting, configuring, and testing the 3000-OEM 
video processing board on the 3000-IO interface board.  

EAN-Parameter File: Outlines the differences between dynamic and non-dynamic parameter file 
settings and how to correctly save them to the board.  

EAN-Script Development: Describes everything needed to develop and run custom scripts in Lua on the 
1500-OEM and 3000-OEM hardware.  

Interface Command and Control (IDD): Describes the native communications protocol used by the 
SightLine Applications product line. The IDD is also available as a local download on the Software 
Download page 

Panel Plus User Guide: Provides descriptions of all the settings in the Panel Plus application. (Located in 
the Panel Plus application in the Help menu.) 

http://sightlineapplications.com/docs/EAN-Startup-Guide-1500-OEM.pdf
http://sightlineapplications.com/docs/EAN-Startup-Guide-3000-OEM.pdf
http://sightlineapplications.com/docs/EAN-Parameter-File.pdf
http://sightlineapplications.com/docs/EAN-Script-Development.pdf
http://sightlineapplications.com/idd/
http://sightlineapplications.com/support/software-downloads/
http://sightlineapplications.com/support/software-downloads/
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1.3 SightLine Software Requirements 

 IMPORTANT: The Panel Plus software version should match the firmware version running on the 
board. 

2 Upgrade Utility Download and Installation 

1. Go to the SightLine software download page and select a version of firmware. Selecting the link will 
initiate the download process.  

2. Open zip file and right click on the .msi file and select Install.  

3. Accept all the defaults for installing the upgrade utility.  

 The installer (by default) installs Bin and Firmware folders under C:\Program Files 
(x86)\SightLine Applications\SLA-xxxx Upgrade Utility m.nn.rrr. The Bin folder contains the 
upgrade utility and library files needed for the utility. The Firmware folder contains all necessary 
files needed to upgrade the board.  

4. Click Close when complete.  

3 Using the Upgrade Utility  

Use the following process to start the upgrade utility and connect to the video processing board. 

 IMPORTANT: If you have multiple versions of firmware on your PC, make sure to open the correct 
upgrade utility application that matches the firmware and board you are upgrading to. 

1. From the Windows Start menu, go to the SightLine application folder and click on the upgrade 
utility tool to open it.  

 When the application starts for the first time, Windows may prompt a dialog regarding firewall 
access. Select Allow for the update to continue.  

2. Click the Find IP Addresses button to get a list of boards on the network. Click on the appropriate 
board to select it. 

 

3. The upgrade utility application in now ready to use. 

 

 

 

 

 

List of boards  

http://sightlineapplications.com/support/software/
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4 Updating the Firmware 

 IMPORTANT:  

• For version firmware level upgrades, i.e., 2. 22.x to 2. 23.x, it is important to remove the 
parameter file from the board (see step 3 below). Older versions of parameter files may not be 
compatible with newer versions of firmware.  

• For sub-version updates, i.e. 2.23.05 to 2.23.09, it is typically not important to check the 
Remove the Parameter File check-box.  

• Before removing the parameter file, record the current network, passthrough, and camera 
configuration settings, since these settings will be lost once the parameter file is removed from 
the board. 

Recommended: Save a backup copy of the current license file and parameter file before upgrading the 
board (see Retrieving the Parameter File and Retrieving a License File). 

1. Start the upgrade utility, Find the boards on the network and highlight the line of the board to 
select it. 

2. Check the Remove Parameter File box if doing a version firmware level upgrade.  

3. Click the Upgrade button.  

 

4. Click Yes in the dialogue box to continue. The application interface will lock until the upgrade is 
complete (approximately 1 minute).  

5. The Status window displays Upgrade DONE when the process is complete.  

6. Click the Find IP Addresses button again to verify that the firmware version number on board is 
now the new version.  

 

7. Restart the board.  

 

 

Check box to remove 
parameter file  
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5 Updating the License File  

 IMPORTANT: Before proceeding make sure that all SightLine software applications are closed. 

This procedure describes how to retrieve a license file from the OEM board. This is useful when a 
license file needs new application bit and to unlock new features on the board. It is common that 
SightLine support will ask for customers to retrieve and send a license file from a unit.  

Recommended:  Save a backup copy of the current license file upon receipt of a board, and before 
upgrading the board. A saved license file can save time and expense if repair work is being done.  

5.1 Retrieving a License File 

1. Start the upgrade utility and select the board. 

2. Select File » License File » Get… 

3. The Browse for Folder window opens. Choose a directory to put the license file. The Browse 
window defaults to C:\Users\<username>\AppData\Roaming\SightLineApplications, but the file can 
be put in any PC or network directory with writing permissions.  

4. Click OK in the Browse for Folder window. The Status window displays Successfully Received License 
File when complete.  

 

5.2 Upload a New License File 

After receiving a new license file from SightLine (normally attached to an email), save it to a known PC 
or network directory.  

1. Start the upgrade utility and select the board. 

2. Select File » License File » Put…  

3. The Browse for Folder window opens. Navigate to the directory that the new license file is in.  

4. Click OK to copy the new license file to the board. The Status window displays Successfully Sent File 
when complete.  

 

5. Restart the board to activate the new license file.  
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5.3 License File Details 

Each license file is generated for a specific board and must be loaded on that board. The upgrade utility 
will only upload or download a license file that matches the hardware ID of the board. Multiple license 
files can be placed in a folder. The upgrade utility will upload the one that matches the board’s 
hardware ID.   

The name of the license file includes the hardware ID. This is not the same as the board serial number, 
which can be found on the board and can be difficult to read. An example license file name is 
3c943c9448eada74.license. An example board serial number is M39741-001-0033.  

To license or upgrade a board, download the license file from the board and send it to Support. See 
section 7 for instructions to download the license file. 

To find the hardware ID, connect to the unit with Panel Plus and go to the main menu » Help » About 
Board.  The dialog will show the hardware ID and related hardware and firmware information.  

 IMPORTANT: Clicking OK will download the license file and parameter file to the host PC download 
directory (C:\Users\Username\Downloads). 

 

Figure 1: About the Connected Board 

If a license file not matching the hardware ID is uploaded to the board, this license file will be ignored. 

If a board is powered up without a license file, a new license file with App Bits 0x0000000 will be 
generated automatically.   

6 Managing the Parameter File 

The parameter file on each board contains system and configuration startup settings. See EAN-
Parameter File for more information about parameter file settings and how to correctly save them to 
the board.  

All systems have the following parameter file name: param51ac4a9a. txt. The upgrade utility can be 
used to remove, upload, or archive a parameter file from a system for unit recovery.  

 IMPORTANT:  The upgrade utility can also be used to propagate a known parameter file to multiple 
units allowing production teams to quickly duplicate settings across systems. Since all settings are 
contained in the parameter file, including network IP addresses, make sure the settings in the file 
will not cause a conflict in other systems when propagating files. 

BoardType: SLA3000 (RevB) 
AppBIts: 0xFFFF 
Hardware ID: 3c943c9448eada74 
Firmware Ver: 2.24.14.30, temp: 149°F 
SVN Revision: 41383, Build Date: 5/7/2018, Build Time: 15:24:25 

mailto:support@sightlineapplications.com
http://sightlineapplications.com/docs/EAN-Parameter-File.pdf
http://sightlineapplications.com/docs/EAN-Parameter-File.pdf
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6.1 Retrieving a Parameter File 

1. Start the upgrade utility and select the board.  

2. Select File » Parameter File » Get… 

3. The Browse for Folder window opens. Choose a directory to put the parameter file. The Browse 
window defaults to C:\Users\<username>\AppData\Roaming\SightLineApplications, but the file can 
be put in any known PC or network directory.  

4. Click OK in the Browse for Folder window. The Status window displays Successfully Received 
Parameter File when complete.  

 

6.2 Upload a Parameter File 

1. Start the upgrade utility and select the board. 

2. Select File » Parameter File » Put…  

3. The Browse for Folder window opens. Navigate to the directory that the new parameter file is in.  

4. Click OK to copy the new parameter file to the board. The Status window displays Successfully Sent 
Parameter File when complete.  

 

5. Restart the board to activate the parameter file.  

6.3 Removing a Parameter File 

1. Start the upgrade utility and select the board. 

2. Select File » Parameter File » Remove.  

3. Click Yes in the dialog window to remove the file. The utility removes the parameter file from the 
board and saves a copy in C:\Users\<username>\AppData\Roaming\SightLineApplications.  
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7 Logo, Splash Screen and Program Files 

The upgrade utility can also be used to manage Logo, Splash Screen and Program Files. File types and 
definitions are shown in Table 1. 

Table 1: Logo, Splash Screen and Program Files 

File File Type Explanation 

User Logo 
(watermark) 

userLogo.png Used for displaying a watermark. When creating a logo file, size the logo to 
fit in the video frame size of the camera that is being used.  

The logo is aligned to the bottom-right corner of the frame. If it is too large 
to fit in the frame the software will use the bottom-right part of the logo file. 
The file is re-scaled by 1/2 only if it is 640X150 pixels for backwards 
compatibility. 

When creating a logo file, the software will sample the pixel on the top left 
corner of the logo. This color becomes the transparent background. 

To view the logo, open Panel Plus and go to Configure » Overlays. Check the 
Logo Watermark box in the Overlay Settings dialog window. The logo will 
become visible. The opacity and position of the logo can be controlled from 
the main menu » Configure » Logo Parameters. 

Splash Screen splash.jpg Used for displaying a splash screen at startup. It is displayed until the unit 
receives a SightLine command. The splash image is zoomed to cover the 
entire video maintaining the aspect ratio, then cropped if needed.  

Make the aspect ratio the same as the camera, e.g., 16x9 ratio for 1280x720 
camera. For NTSC camera 720x480 (or that ratio) is recommended.  

Program Files *.lua,*.so Used for custom scripts or custom DLLs. See EAN-Script Development for 
more information.  

7.1 Uploading a File 

1. Start the firmware upgrade utility and select the board. 

2. Select File » XXX » Put… The Browse for Folder window opens.  

3. Navigate to the directory that the new file is in. Click OK to copy the new file to the board. The 
Status window displays the result when complete.  

4. Restart the board for the change to take effect.  

7.2 Retrieving a File 

1. Start the firmware upgrade utility and select the board.  

2. Select File » XXX » Get… The Browse for Folder window opens.  

3. Choose a directory to put the file.  

4. Click OK to copy the file from the board. The Status window displays the result when complete.  

7.3 Removing a File 

1. Start the firmware upgrade utility and select the board.  

2. Select File » XXX » Remove.  

3. The Status window displays the result when complete.  

http://sightlineapplications.com/docs/EAN-Script-Development.pdf
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8 Advanced Menu 

Reset Board (Reboot): Restarts the board.  

Set IP Address: Temporarily sets an IP address to the board. This is useful when troubleshooting a 
network issue, i.e., the board is on a different subnet. In that case, assign a temporary IP address to the 
board so that it can be connected from the Panel Plus application. The temporary address is not saved 
(unless it is saved to the parameter file from Panel Plus). The board will revert to the original address 
when the board is restarted.  

Make Writeable (3000-OEM): This option allows users to use other utilities (WinSCP or FileZilla) to 
copy custom program files to the file system or library files of the 3000-OEM board.  

 CAUTION: This is an advanced option and could potentially lockup or damage the board. If you 
are unsure how to proceed, contact SightLine Support before proceeding.  

The filesystem is read-only on the 3000-OEM. To copy files to the 3000-OEM with another utility, the 
filesystem must be made temporarily writeable.  

1. Start the firmware upgrade utility and select the board.  

2. Form the main menu, go to File » Advanced and select Make Writeable.  

 

3. Click Yes in the dialog window to load the file.  

4. Restart the board for the change to take effect.  

 

 

 

 

 

 

 

 

mailto:support@sightlineapplications.com
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9 Command Line File Management 

This section describes how to use command line versions of the SightLine upgrade utilities from a 
Windows CMD window or WSL shell to manage system files.  

There are two versions of the command line upgrade utility: 

• SLAUpgradeCmd.exe:   Runs in a Windows CMD shell. It is distributed in the bin directory of every 
firmware distribution. 

• SLAUpgradeCmd:  Runs in a shell on a 64-bit Linux system. Ubuntu 18.04 running under WSL is 
currently supported. See Installing and Running Linux. 

Both programs provide: 

- the same functionality and have the same command line options.   

- support paths using a forward slash (/) as a separator. The Windows CMD version also supports a 
backslash (\) as a path separator for paths on the PC host.  Do not mix the forward slash (/) and 
backslash (\) within a single path.  

Examples throughout the document will assume the Windows executable name.  

It is assumed that the PC host and a target system (3000-OEM or 1500-OEM) are connected by a 
network (Figure 2). 

 

Figure 2: PC Host and Target System Network 

9.1 Command Options 

To see the options, run with -?: 

SLAUpgradeCmd.exe -IP <IPAddress>[-UP <Firmware Directory>][-DP][-GF 

<localDirectory> <remoteName>][-SF <localName> <remoteName>][-GL 

<localDirectory>][-SL <localDirectory>] 

 

-IP <IPAddress> (Required) Indicate the IP Address of the target (e.g., 192.168.1.75) 

-UP <Firmware Directory> Upgrade Firmware. Specify directory containing the upgrade files.   

-DP  Delete parameter file during upgrade (recommended).  Currently 
only works when -UP is used 

-GF <localDirectory> <remoteName> Get file remoteName and download it to localDirectory 

-SF <localName> <remoteName> Copy file localName and send it to destination file remoteName. 

-GL <localDirectory> Get License file from SLA board to localDirectory. 

-SL <localDirectory> Send License file from localDirectory to SLA board. 

Host PC 

WSL or Similar Linux 

3000-OEM or 1500-OEM  

Ethernet Cable 

 

Network Switch 
or Direct connection 
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9.2 Issues 

• The firmware upgrade will not be completed if the same revision of firmware is already loaded on 
the system. 

\bin>SLAUpgradecmd.exe -IP 192.168.1.114 -UP ../firmware/ 

Update not necessary, already at svnRevision 43635 

• The firmware upgrade utility does not provide status message if the firmware update procedure 
succeeds. 

• Wildcards are not supported with Get File (GF) option. 

• Directory names should end in a forward slash (/) or backslash (\).  

▪ GOOD - C:/temp/mySLAdir/    

▪ BAD - C:/temp/mySLAdir      

• Use  ./ or  .\  to indicate the directory local to the executable. In this example the command 
downloads the license file and places it in the same directory as SLAUpgradeCmd. 

SLAUpgradeCmd.exe -IP 192.168.1.75 –GL ./ 

• Use quotes around directory and file names when there are spaces in the name: 

Good: SLAUpgradeCmd.exe -IP 192.168.1.75 -UP "C:/Program Files (x86)/SightLine 
Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/" 

 

Bad: SLAUpgradeCmd.exe -IP 192.168.1.75 -UP C:/Program Files (x86)/SightLine 

Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/ 

9.3 Command Examples 

Upgrade 3000-OEM from installed firmware: 

SLAUpgradeCmd.exe -IP 192.168.1.75 -UP "C:/Program Files (x86)/SightLine 

Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/" 

 

SLAUpgradeCmd.exe -IP 192.168.1.75 -UP ../firmware/ 

Upgrade 1500-OEM firmware and remove parameter file during the upgrade: 

SLAUpgradeCmd.exe -IP 192.168.1.71 -DP -UP "C:/Program Files 

(x86)/SightLine Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/" 

Get the parameter file (from board to PC): 

SLAUpgradeCmd.exe -IP 192.168.1.75 -GF C:/temp/param51ac9a4a.txt 

./param51ac9a4a.txt  

Set the parameter file (from PC to board): 

SLAUpgradeCmd.exe -IP 192.168.1.75 -SF C:/temp/param51ac9a4a_3000.txt 

param51ac9a4a.txt 
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Get the license file (from board to PC):  

The license file name depends on the board hardware ID. The upgrade utility determines the correct 
file name based on the hardware ID. The filename does not need to be specified, only the path.  

SLAUpgradeCmd.exe -IP 192.168.1.75 -GL C:/temp/ 

 

SLAUpgradeCmd.exe -IP 192.168.1.75 -GL ./ 

Set the license file (from PC to board):  

The license file name depends on the board hardware ID. 

SLAUpgradeCmd.exe -IP 192.168.1.75 -SL C:/temp/ 

Copy a script file (from PC to the board): 

SLAUpgradeCmd.exe -IP 192.168.1.75 -GF "C:/temp/tracksnap.lua" tracksnap.lua 

Copy a watermark logo file from PC to the board: 

SLAUpgradeCmd.exe -IP 192.168.1.75 -SF "C:/temp/userLogo.png" userLogo.png 

9.4 Upgrade Utility and Command Line Utility 

The following table shows the user interface differences between the Upgrade Utility and the 
Command Line Utility. 

Table 2: User Interface Differences - Upgrade Utility and Command Line Utility 

Upgrade Utility UI Command Line Utility Upgrade Utility UI Command Line Utility 

License File Get & Put Use -GL or -SL option User Logo File Get & Put Use -GF or -SF option  

Parameter File Get & Put Use -GF or -SF option User Logo File Remove Not yet implemented 

Parameter File Remove Not yet implemented as 
standalone operation. 

Can be deleted using the -
DF option when upgrading 
(-UP). 

Advanced » Reset Board Not yet implemented 

Program Files Get & Put Use -GF or -SF option Advanced » Set IP Address Not yet implemented 

Splash Screen File Get & Put Use -GF or -SF option Advanced » Make Writable Not yet implemented 

Splash Screen File Remove Not yet implemented   

9.5 Installing and Running Linux 

The program is developed using 64-bit Ubuntu 18.04, under WSL. 32-bit Linux is not supported. 
Running on native Ubuntu 16.04 has been tested, but the results have been poor with Ubuntu 16.04 
running in VirtualBox. Ubuntu 16.04 under WSL has not been tested. 

The program and firmware are distributed in a gzip TAR file. Use the following steps to install and run 
from the TAR file. This example assumes the target is a 1500-OEM, at address 192.168.1.211, and the 
firmware to be loaded is version 2.25.04. 
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1. Choose a directory to start. In a Linux terminal window create a temporary directory (tmpDir). Copy 
the tar file to it, and then cd to it. Type: 

mkdir tmpDir 

cp ~/Downloads/SLAUpgrade1500_2_25_04.tgz tmpDir 

cd tmpDir 

2. Unpack the contents of the .tgz file to a local directory tree. Type: 

tar -zxvf SLAUpgrade1500_2_25_04.tgz 

3. Use the change directory command and type:  

cd “SightLine Applications/SLA-1500 Upgrade Utility 2.25.04” 

The bin and firmware directories are now in your current directory.  

4. Type:   

bin/SLAUpgradeCmd -?   

A usage message should display. 

5. Type:   

bin/SLAUpgradeCmd -IP 192.168.1.211 -UP ./firmware/  

This will upgrade the target. 

9.6 Troubleshooting  

Problem Recommendation 

Program does not run Try running with -? argument. 

Linux version only runs on 64-bit hosts. 

Upgrade fails Make sure target is up and running on specified IP address. 

Use Panel+ to try to connect to unit 

Make sure host and target are on same network. 

Use ping to query the unit 

Target won’t run after failed upgrade  Try power-cycling target.  

Follow instructions in Appendix A for updating firmware 
with MicroSD card. 

Failed to upgrade <IP Address> Check network connection, cables, etc. 

Check network adapter is enabled (ifconfig) 

 

Why FTP cannot be used to push files 
to the target. 

The target file system is Read Only by default. When using 
the upgrade utility, the remote file system management is 
maintained. 

10 Questions and Additional Support 

If you are still having issues and require additional support, please contact Technical Support. 
Additional support, documentation and Engineering Application Notes (EANs) can be found on the 
Support pages of the SightLine Applications website. 

mailto:support@sightlineapplications.com
http://sightlineapplications.com/support/documentation/
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Appendix A: Updating Firmware with MicroSD Card 

This section covers how to update the 1500-OEM and 3000-OEM board firmware using a microSD card. 
This process is useful for recovering a board that is either not working as designed or is not 
communicating.  

Before updating the firmware, the microSD card must first be formatted using MiniTool Partition 
Wizard available on the MiniTool website.  

 A microSD card reader is needed for this procedure. If your PC does not have a built-in reader, use 
an external USB microSD card reader or similar.  

A1 MicroSD Card Types 

The part numbers listed in EAN-File-Recording Appendix B have been verified to work with the 1500-
OEM and 3000-OEM processors. 

 SightLine recommends Class 10 microSD cards. Class 10 cards are rated for a minimum sequential 
write speed of 10 MBps or greater. 

A1.1 1500-OEM Known Incompatible Cards 

The cards listed in the table below are not usable as bootable media for performing firmware upgrades 
on the 1500-OEM. These parts have been verified to work for recording and mass storage purposes. 

Manufacturer Model Revision 

SanDisk SDC10G2/32GB N0591-002.A00LF 

SanDisk SDC10G2/32GB 31629-001.A00LF 

SanDisk SDCS/32GB N0686-008.A00LF 

A2 Formatting the MicroSD Card as Bootable Media 

Before starting this procedure, download and install the MiniTool Partition Wizard software.  

A specific partition size is required for the microSD recovery card. The partition size should be set to 
1GB (or less). The partition file system types will also need to be changed. For the recovery card, the 
file system type is required to be set to FAT, Primary, and Active.  

1. Insert the microSD card into the card reader on the PC.  

2. Open the MiniTool application.  

3. From the list of drives, highlight the microSD card by clicking on it.  

 

 

https://www.partitionwizard.com/download.html
http://sightlineapplications.com/docs/EAN-File-Recording#page=19
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4. From the Partition Management list, click Delete Partition.  

 

5. From the Partition Management list, click Create Partition.  

 

6. In the Create New Partition window, enter/change the following fields: 

• Optional - Partition Label: 1500_ vx. xx. xx or 3000_vx. xx. xx (x = firmware number)  

• Create As: Primary 

• File System: FAT 

• Partition Size: 1000 MB. The MiniTool software may default to 999 MB. This is acceptable.  

 

7. Click Ok.  
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8. Right-click on the microSD Card in the list and select Set Active from the dropdown list to make the 
card active. The Status column displays Active.  

 

9. Click Apply from the top menu bar. The operations status screen shows the progress of creating 
and setting of the partition values.  

                                        

10. When complete, a status message will be displayed. Click OK and close the application.  

11. This concludes the formatting process. Proceed to the next section to update the firmware.  

A3 Updating the Firmware 

The files that are needed for this procedure are located on the PC in the Upgrade Utility folder.  

 IMPORTANT: Make sure the microSD card has been formatted before starting this procedure.  

1. Choose the appropriate board firmware. Go to C:\Program Files (x86)\SightLine Applications\SLA-
xxxx Upgrade Utility m.nn.rrr\firmware.  

2. Copy all the files in the Firmware folder to the root directory of the newly formatted microSD card. 

 

3. Once the files have been copied to the microSD card, remove it from card reader.  

Copy all the files  
(files are different for 3000) 

MicroSD card 
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4. Make sure the OEM board is powered off. Insert the microSD card in the microSD slot on the 
appropriate board as shown in Figure A1. 

   

Figure A1: 1500 and 3000 Board MicroSD Card Slots 

5. Power up the board to start the update. This process takes approximately three minutes.  

 If an analog monitor is connected to the 1500-OEM, a successful/completed message is displayed 
when the firmware upload is complete. If a monitor is not connected, wait for the onboard LED on 
the 1500-SOM to flash once every second. This indicates the firmware upload is complete. For 3000-
OEM wait for at least 3 minutes since there is no indication when the update is complete. 

6. Remove the microSD card and power cycle the board for the new firmware to take effect. 

 

 

 

 

 

 

 

 

 

 

 

 

  

MicroSD 
card slot 

1500-OEM 

MicroSD 
card slot 

3000-OEM 
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Appendix B: Manually Deleting Files 

B1 Using Command Line Programs 

Tera Term, PuTTY or a similar program can be used to establish an SSH session to the target and delete 
files. The IP address can be read by connecting to the board through Panel Plus. 

1. Establish an SSH session to the target.  

2. Login using the default username and password:  root 

 The 3000-OEM does not require a password. 

3. The 1500-OEM file system has been created with read/write permissions. The 3000-OEM has a 
read only file system. To make it writable, type:  mount -w -o remount / 

4. To see all the files, type:  ls 

5. To remove a file, use:  

rm drawCircle.lua  

sync 

 

Figure B1: Manually Deleting Files with Term Term 

6. If connecting to the 3000-OEM, power cycle the target hardware or type reboot to restart the 
system. When the system reboots the file system will automatically return to read only mode. 

 

 

 

 

 

 

 

 

https://ttssh2.osdn.jp/index.html.en
https://putty.org/


EAN-Firmware-Upgrade-Utility  

© SightLine Applications, Inc.                                                                  18 

B2 Using SightLine Upgrade Utility and FTP Client  

1. Open a 1500 or 3000 Upgrade Utility application. 

2. Click the Find IP Addresses button to see SLA hardware on the network. 

3. Select the target hardware. 

 

4. The 1500-OEM file system has been created with read/write permissions. The 3000-OEM has a 
read only file system. To make it writable, got to the main menu » File » Advanced » Make 
Writable. 

5. Open an FTP client such as FileZilla. Connect to the target hardware IP address using the default 
username and password:  root  

 The 3000-OEM does not require a password. 

 

6. If connecting to the 1500-OEM navigate to the /root directory. If connecting to the 3000-OEM 
navigate to /home/root. 

 

7. Right-click on the file and select Delete. 

 

 If connecting to the 3000-OEM, power cycle the target hardware or type reboot to restart the 
system. When the system reboots the file system will automatically return to read only mode. 
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