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1

Overview

This document provides information and steps for developing and running custom scripts in Lua for the
1500-OEM and 3000-OEM video processing boards.
1.1

Associated Documents

EAN-Firmware Upgrade Utility Guide: Outlines the steps for installing and running the Firmware
Upgrade Utility to manage the firmware, parameter, license and other program files critical to
hardware and software functions.
EAN-Startup Guide 1500-OEM: Describes steps for connecting, configuring, and testing the 1500-OEM
video processing board on the 1500-AB accessory board.
EAN-Startup Guide 3000-OEM: Describes steps for connecting, configuring, and testing the 3000-OEM
video processing board on the 3000-IO interface board.
EAN-Managing the Parameter File: Outlines the differences between dynamic and non-dynamic
parameter file settings and how to correctly save them to the board.
Interface Command and Control (IDD): Describes the native communications protocol used by the
SightLine Applications product line. The IDD is also available as a local download on the Software
Download page.
Panel Plus User Guide: Provides descriptions of all the settings in the Panel Plus application. (Located in
the Panel Plus application in the Help menu.)
1.2

Hardware Compatibility

Standard Ethernet network or serial connection to the SightLine hardware.
1.3

SightLine Software Requirements

Example Scripts

Software Version

Script Interfaces

Software Version

helloworld.lua (updated)

2.24.xx

SLUnload

2.24.xx

lensctrl.lua

2.24.xx

SLLoad

2.24.xx

reticles.lua

2.24.xx

SLNewCmdCallback

2.24.xx

snapshot.lua

2.23.xx

SLPostAnalyze

2.23.xx

gpio.lua

2.23.xx

The 3000-OEM (REV C) requires firmware 2.24.xx and higher.

 IMPORTANT: The Panel Plus software version should match the firmware version running on the
board.
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Example Scripts

The sample applications/scripts installer (SLA ARM Examples) can be downloaded from the SightLine
Applications website. Run this installer before setting up the development environment.
The example scripts are intended to serve as a starting point for any script development. A summary of
each example script is shown below. Some example scripts in the directory are not shown below since
they are used internally.
•

helloworld.lua: Sends a command to the SLA software (VideoTrack) to draw a text overlay with the
following text: Hello World. The example program is updated in 2.24 to remove the overlay when
the script is unloaded.

•

snapshot.lua: Retrieves the current version of SLA software, starts a track at coordinates
320x,240y, and then takes a snapshot. This example highlights sending commands to the board and
retrieving information.

•

gpio.lua: Toggles the GPIO based on MTI detections. See the EAN-GPIO for more information on
available GPIO on the 1500-OEM and 3000-OEM. This example uses GPIO 175, which is a valid GPIO
for the 1500-OEM. The example highlights how to get telemetry from the SLA software, and how to
set GPIO from a script.

•

lensctrl.lua: (New in 2.24.xx) A complex script that provides example implementations of auto focus
algorithms and other lens control functions. More details can be found in the Appendix A.1.

•

reticles.lua: (New in 2.24.xx) Script to generate custom on screen display reticles. User can
configure reticles for camera. There are four different types of reticles to choose for each camera.
Configuration details for reticles script can be found in the Appendix A.2.

3

Development Environment

Lua scripts can be developed with almost any IDE, however to get syntax highlighting, static analysis,
and autocomplete capabilities, SightLine recommends using the ZeroBrane IDE from ZeroBrane Studio.
In this example, the application has been installed to C:\ZeroBraneStudio. The steps below reference
the install location as ZBS.
1. Download and install ZeroBrane IDE from ZeroBrane Studio.
2. Find sla_internal.lua in the installed sample directory /SightLine Applications/SLA-Examples-ARM
2.**.**/SLAScripts/ and copy it into ZBS\api\lua.
For version 2.23.xx, find - sla.lua
3. Open ZeroBrane Studio and choose the menu option project directory: Project » Project Directory »
Choose.
4. Select the directory with the example scripts. C:\SightLine Applications\SLA-Examples-ARM
2.**.**\SLAScripts\Scripts.
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5. Choose the menu option Edit » Preferences » Settings:User. This opens a user settings file. Add the
following line to end of the file:
api = {'sla_internal'}
For version 2.23.xx add the following line to the end of the file: api = {'sla'}
6. Restart the ZeroBrane Studio application.
7. At this point the helloworld.lua example can be edited. To verify autocomplete is working, type ffi.n
after the definition of framecount. It should now show new as an option.

Note: ZeroBrane Studio includes a static analyzer. To use this, go to the menu option Project » Analyze
after editing a file. This is strongly recommended before sending files to the SLA-hardware. If using a
different IDE that doesn't contain a static analyzer, there are other third-party tools available on the
web.

4

Uploading Scripts

User developed scripts can be uploaded to the SLA-hardware using the SLA-firmware upgrade utility.
1. From the upgrade utility menu select File » Program Files » Put Files (PC » SLA)...

2. Select the directory containing the developed Lua scripts or the Example scripts directory. This
uploads the *.lua files from that directory to the SLA-hardware.
Note: The upgrade utility can also be used to retrieve all the scripts from the hardware.
3. Once the scripts are uploaded they can now be enabled. (See Enabling / Disabling Scripts).
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Enabling / Disabling Scripts

Scripts can only run if they are enabled. This can be done through FIP using the Set External Program
(0x8F) message. It can also be done from the External Programs dialog window in Panel Plus. From the
main menu, go to File » Programs.
To enable a specific script, select it in the drop-down menu and click Send. To disable a script, select
None and click Send.
To run the script at startup, enable the script and then save the settings to the board (main menu »
Parameters » Save to board). Sending the message again, or clicking the Send button again will cause
the scripts to be reloaded.
Note: If you have a script that uses another script internally, include the keyword “internal” in the script
name and it will not show up in the Panel Plus list of programs.

Figure 1: External Programs

 IMPORTANT: Problems with scripts show up as a user warning. When loading scripts, it is
important to monitor the User Warning dialog window. From the Panel Plus main menu, go to View
» User Warning.

Figure 2: User Warning
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Script Interface

The script interface to VideoTrack is documented in the IDD. The IDD provides all the details on
structures, functions, etc. available through the script interface. The key interfaces from VideoTrack to
the script are documented below.
SLPostAnalyze:
This function is called by VideoTrack immediately after the analysis of a frame is complete. The analysis
step includes registration, tracking, detection, etc. All scripts should implement this function.
In the helloworld.lua example, this function maintains a global framecount, and then uses it to
determine when to draw Hello World on the video. This function is passed two parameters:
•

_vtstate: This is a handle to the VideoTrack context and is needed in calls back to the VideoTrack
program such as ffi.C.SLADrawObject shown in the example.

•

cameraIndex: This provides the camera index for which the script is being called. The user may
want to take actions only on a specific camera or keep camera specific data separate. On the 3000OEM, the SLPostAnalyze function will be called for all actively processed cameras.
Note: On the SLA-3000 the SLPostAnalyze function will be called for all actively processed cameras,
so it is up to the user to decide how to use the cameraIndex. For example, you may only want to
draw Hello World for camera two in which case you could simply return at the top of SLPostAnalyze
if the camera index is not equal to two.

Figure 3: SLPostAnalyze usage from Hello World Example
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SLUnload (New in 2.24.xx):
This function is called by VideoTrack whenever the script is disabled. This can happen if the board is
shutting down or if the script is disabled through Panel Plus. In the helloworld.lua example, this
function removes the drawObject with id 98 created in SLPostAnalyze. This function is passed only one
parameter:
•

_vtstate: This is a handle to the VideoTrack context and is needed in calls back to the VideoTrack
program such as ffi.C.SLADrawObject shown in the example.

Figure 4: SLUnload Usage from Hello World Example

SLLoad (New in 2.24.xx):
This function is called by VideoTrack when loading the script. This function is passed only one
parameter:
•

_vtstate: This is a handle to the VideoTrack context and is needed in calls back to the VideoTrack
program.

SLNewCmdCallback (New in 2.24.xx):
This function is called by VideoTrack when it receives a command. This function is passed four
parameters:
•

_vtstate: This is a handle to the VideoTrack context and is needed in calls back to the VideoTrack
program.

•

_temp: This is a handle to the structure containing the message data.

•

len: This is the length of the message data.

•

type: This is the message type

Figure 5: SLNewCmdCallback Example
© SightLine Applications, Inc.
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Trouble Shooting

Problem

Recommendation

Script does not run.

From the Panel Plus main menu, go to View » User
Warnings and enable the user warnings. Start the script
and monitor the User Warning dialog window to determine
if there are any User Warning preventing the script from
running.

Cannot debug script.

Print statements are helpful but require access to the Linux
console to see the output. This requires a serial connection
as well as modifying the silent argument in u-boot. Contact
support if you have further questions on how to do this.
Additionally, debug statements can be drawn to the screen
in the same manner using the helloworld.lua example.

System is sluggish after loading script.

From the Panel Plus main menu, go to View » Performance
Graphs. Select Enable System Status and CPU Timing. After
a few seconds ARM should appear in the list of timings.
Expand this and look at the time for Post AnalyzeScript. The
times presented are (Average, Minimum, Maximum) over
100 samples in microseconds. If these numbers are very
large, e.g., several thousand microseconds, reevaluate the
level of complexity of the script.

7.1

Questions and Additional Support

If you are still having issues and require additional support, please contact Technical Support.
Additional support, documentation and Engineering Application Notes (EANs) can be found on the
Support pages of the SightLine Applications website.
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Appendix
A.1

Lens Control Script

New in software version 2.24.xx.
A.1.1 Overview
The lens control example script shows users how to implement a basic auto focus algorithm in Lua. It
also shows how to receive lens commands sent from Panel Plus or another user interface and translate
those commands into lens commands such as zoom or focus.
This example also shows how to interface with a serial port from Lua, how to do bitwise operations in
Lua, plus many other helpful functions. This script was not designed to provide an out-of-the box auto
focus algorithm that is plug-and-play for any system. An in-depth knowledge of the lens and camera
system is required to take this from an example and turn it into a working product.
A.1.2 Testing 1500/3000

 IMPORTANT: A Sony or Hitachi camera is needed for this procedure.
The following instructions assume a working knowledge of how to modify and load scripts to the SLAhardware.
1. Using Panel Plus, configure the system to stream video from the digital camera.
2. In Panel Plus verify that serial port 2 is configured as Port Not Used. If not, make the change, save
the parameters, and then restart the system.
3. Open the Lens tab in Panel Plus and verify that the Lens Type is set to None. If not, make the
change, save parameters, and then restart the system.

4. To switch from the Sony to the Hitachi camera, edit lensctrl.lua to require the
hitachictrl_internal.lua script as shown below.

5. Send the scripts to the 1500-OEM/3000-OEM, and then load the lensctrl.lua script.
6. Verify basic functionality by using the Narrow or Wide zoom controls.
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7. Basic troubleshooting:
a. Monitor the user warnings in Panel Plus.
b. If there are no user warnings and the camera is not responding, try different baud rates.
Common baud rates for the Hitachi are 4800 and 9600. Common baud rates for the Sony are
9600 and 19200.
c. If the camera is still not responding, contact SightLine Technical Support.
8. 3000 Specifics:
a. The 3000-OEM serial ports are slightly different. If the camera is connected on VIN0 no
changes should be needed. If the camera is connected on VIN1, the scripts that open serial
ports need to be updated to port 3 instead of serial port 2 (see sonyctrl_internal.lua or
hitachictrl_internal.lua).
b. If multiple cameras are being processed on the 3000-OEM, add code to exit early from the
SLPostAnalyze function for the non-lens controlled camera. See Figure 6.

Figure 6: SLPostAnalyze Script Example

c. The example script does not check the commanded camera. To create auto focus scripts for
two different cameras, additional code will need to be added to check the camera in the
SLNewCmdCallback function.

A.2

Reticle Selection Script

New in software version 2.24.xx.
A.2.1 Overview
Reticle selection scripts can be used to draw overlay reticles on top of the stream and can be
customized for each camera.
Two script files are available:
1. ReticlesConfig_internal.lua: Configuration parameters to customize the display of reticles.
2. Reticles.lua: Responsible for adding reticle to the display image. Is the primary script file that

should be loaded to the target to display the reticles on the screen.
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A.2.2 Configuring Reticle Scripts

 IMPORTANT: Make sure to edit reticlesConfig_internal.lua with a text editor before uploading
reticles.lua to the hardware.
Table 1: User Configuration Parameters

Parameter

Description

CAM<X>_RETICLE_INDEX

Reticle to draw for camera with index X. See Reticle index section for
available options.

CAM<X>_FIELD_OF_VIEW

Field of view of camera with index X (degrees).

CAM<X>_CIRCLE_DEGREE

Diameter of Circle (degree) of camera with index X.

CAM<X>_CENTER_CIRCLE_RADIUS Radius of the center point (circle) of camera with index X, default is 2.
CAM<X>_COLOR_FOREGROUND

Foreground color(Color 1) to draw for camera with index X. Check Reticle
Color mapping section for options.

CAM<X>_COLOR_BACKGROUND

Background color(Color 2) to draw for camera with index X. Check Reticle
color mapping section for options.

Example setting for Camera 1:
CAM1_RETICLE_INDEX = 2
– set camera 1 to use reticle with index 2
CAM1_COLOR_FOREGROUND = 13
– set camera 1 foreground color as yellow
CAM1_COLOR_BACKGROUND = 12
– set camera 1 background color to orange
CAM1_FIELD_OF_VIEW = 50
– set camera 1 field of view to 50 degrees
CAM1_CIRCLE_DEGREE = 10
– set camera 1 field of view to 10 degrees
CAM1_CENTER_CIRCLE_RADIUS = 2
– set camera 1 center point radius to 2.
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Field of View: Field of view of camera (degrees) is used to calculate the size of lines used to draw the
overlays.
Circle Degree: Diameter of Circle (degree) relative to the field of view.
Center Circle Radius: Center point used in some reticles. Diameter of the circle in Degrees.
A.2.2.1 Reticle Color Mapping

Reticle color mapping to be used for background and foreground color settings in the configuration
file.
Table 2: Reticle Color Mapping

Color

Value

Color

Value

WHITE

0

DARK BLUE

7

BLACK

1

LIGHT GREEN

8

LIGHT GRAY

2

GREEN

9

GRAY

3

DARK GREEN

10

DARK GRAY

4

RED

11

LIGHT BLUE

5

ORANGE

12

BLUE

6

YELLOW

13

A.2.2.2 Reticle Index

There are four different types of reticles available now with index ranging from 0 to 3. Each camera
index is assigned a single reticle. To choose a different reticle for a certain camera change
corresponding camera reticle index. For example: To change camera 2 to use reticle with index 0
change CAM2_RETICLE_INDEX = 0. All the reticles will be drawn with the same color combination
based on COLOR_TO_DRAW value.
Table 3: Reticle Indexes

Reticle Index
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