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Troubleshooting Comms Overview

This document reviews frequent network questions and common system connection problems.
Problem

Possible Cause

Solution

Software,
documentation
or sample code
Software
installation

All software is available
online.

Browse or search at the SightLine software-downloads page and the documentation
support page.

Conflict with previous
revision

Uninstall previous revision and delete any artifact directories
(e.g. C:\Program Files (x86)\SightLine Applications\SLA-1500 Upgrade Utility 2.24.16)

No connection

Connected to wrong
connector
Bad cables

Check the product ICD to verify the connector is correct.

Incompatible display

Try a known working input source (camera or DVD player, monitor) to verify the
display is working.

No Video Source

Verify the camera (or other source) is functioning by connecting it directly into the
display
Verify correct voltage (5V or 12V depending on unit)
Look for status lights on the board (non-enclosure units)
Use Panel Plus to set the camera order.

No video output /
video is black,
etc.

No power to SightLine
hardware

Serial port is not
working

Unit does not
respond to
command but is
shown on the
network

Wrong Input Source
Selected
Analog Video Out
disabled
Wrong serial port
TX and RX are swapped
Bad serial port
Wrong voltage level
Incorrect or no ground
Incorrectly configured
serial ports
IP address / Network
Mask mismatch

Windows Firewall
Router/Switch issues
Not Connected
Wrong Network Adapter
Bad Parameter File
Unit Firmware Crash
Stalling/stuttering
network video

Configuration problems

Video appears
blue (or some
other color)
Image scrolling,
etc.

Video synchronization
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Verify connectors and cables by hooking them up to other sources.

System was configured for network output only. Use Panel Plus to enable NTSC
output.
Try selecting a different Com Port from Panel Plus
Try using a null modem in line with your cable to the SLA-hardware.
Try hooking your serial port up to another device like a PC and send commands.
Verify with the ICD for your product. Some OEM boards assumes a 3.3V TTL serial
communication.
Verify your serial cable is using the same digital ground as the SLA-hardware.
Connect via Network and configure with: Panel Plus main menu » Configure »Serial
Ports
If a DHCP server is not available, the default IP address for SLA-hardware is
169.254.1.180 (SLA-1500) or 169.254.1.181 (SLA-3000) with a subnet mask of
255.255.0.0.
Set PC to be on the same subnet, and then use Panel Plus to change the network
settings of the SLA-hardware.
Clear the ARP table from the command line (arp -d *).
Disable windows firewall.
Try using a simple (unmanaged) network switch.
Select the unit name from the pull-down list and click Connect.
The IP address, temperature, and firmware version should be visible in the status bar.
Disable all Wireless and other network interfaces except the wired (LAN).
Remove parameter file with Upgrade Utility. See Removing the Parameter File
Remove and restore power to the unit
VideoTrack has crashed (Appendix)
Verify correct network streaming settings
Verify network hardware
Unplug the video source and plugging it back in.
Cycle power to the SLA-hardware after the video source is connected.
Try a different video source.
Verify video source by plugging it directly into a display.
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Power

1. Verify that SLA-PWR-xxxx is functional using
a voltmeter.
2. Verify that power and ground are supplied
to the correct pins. See Figure 1 example.
3. Verify that screw terminals on top of
connector are tight.
4. Verify that power connector is seated firmly
within the socket on the SLA-1500-ENC.
Figure 1: Example 3000-IO Power and Serial Connector

3

Ethernet

1. Make sure all cables are in good condition and firmly connected (swap cables if necessary).
2. Make sure power is supplied to all hardware, network switch, PC, SLA board, etc.
3. Verify that the link lights are active for the port on the network switch where the SLA board is
plugged in.

 A powered switch is recommended for bench testing. If the SLA hardware is directly connected
to the PC and a DHCP server is used, the PC can lose the network connection if the SLA hardware
is disconnected or power cycled. It can take up to three minutes for the PC to reestablish
connection, which can cause a timeout of the DHCP server. This can be avoided by setting the PC
to a static IP address.
4. Verify that the DHCP server can provide an IP Address.
5. If a DHCP server is not used, the SLA board will default to the following IP addresses:
•

1500-OEM: 169.254.1.180 subnet mask 255.255.0.0

•

3000-OEM: 169.254.1.181 subnet mask 255.255.0.0

 Verify that the IP address and subnet mask are valid for your network. For most networks,
255.255.255.0 is the correct subnet mask. For IP addresses in the range 169.254.x.x, 255.255.0.0
is correct.
6. Open a Command Prompt window and use the IPCONFIG command to see the network
configuration. See the following Microsoft support article.
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7. Verify that the PC and SLA board are on the same subnet and using the same subnet mask.

 If there is a subnet mask mismatch between the host PC and the 1500-OEM / 3000-OEM, Panel
Plus will report this problem when connecting to the SLA hardware. Panel Plus uses a broadcast
message (255.255.255.255) to query the network for SightLine units. This allows for discovery
and response across separate networks. Panel Plus will still discover the hardware and will
display a warning about the hardware not being on the same network.
8. Ping the SLA board from the PC.

 Ping may be successful even when Panel Plus is using the wrong network interface.
9. Clear the ARP cache on the PC, type: arp -d *
10. Download and install a network packet analyzer to verify that the SLA board is generating packets.
References: Wireshark / Information about Network Monitor 3
11. Disable Windows Defender or Microsoft Firewall protection. See the following Microsoft support
article.
12. Disable all unused wired and wireless network interfaces. See Microsoft Windows support for more
help information.

 Multiple network interfaces on a PC can confuse Panel Plus or the upgrade server.
 Leave the Wired network enabled.

13. Verify the wired network interface is enabled and connected.

© SightLine Applications, Inc.
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Windows Firewall

Windows firewall can block Panel Plus from accessing the network. The workaround is to modify the
firewall rule that is created when the application is launched for the first time. Windows firewall
manages network access on a per-application basis - a firewall rule is created for each installed version
of Panel Plus.
1. Press Windows KEY+R to open a Run prompt. Enter firewall.cpl.

2. From the sidebar select Allow an app or feature through Windows Defender Firwall.

3. Select Change settings and approve the subsequent user account control prompt.
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4. Check the public and private boxes for each slapanelplus entry.

5. Click OK and close.

5

Removing the Parameter File

If there are no problems with the firewall settings, remove the parameter file using the 1500-OEM /
3000-OEM Upgrade Utility. This should allow a connection to the unit with Panel Plus.
See EAN-Firmware Upgrade Utility for additional parameter file management information.
1. From the Start menu on your PC, go to SightLine Applications and open the appropriate upgrade
utility application.
2. Click the Find IP Addresses button.
3. Select the IP address of the board.

 Before removing the parameter file, record the current network, passthrough, and camera
configuration settings, since these settings will be lost once the parameter file is removed from
the board.
4. From the main menu, go to File » Parameter File » Remove.

5. Click Yes in the dialog window to remove the file. The utility removes the parameter file from the
board and saves a copy in C:\Users\<username>\AppData\Roaming\SightLineApplications.
6. Close the upgrade utility and cycle the board power.
7. In Panel Plus, wait for the system to boot, and then try connecting to the board.
© SightLine Applications, Inc.
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Stuttering / Stalling Network Video

The problem may be that something is causing packet loss, or possibly multiple streams arriving at the
same UDP port on the host PC.
✓ Verify that analog video output is working correctly if possible.
✓ Ensure that there are no other video streams going to the PC (such as from another SightLine board
or some other device). Multiple streams arriving at the same UDP port on the PC can cause packet
loss.
✓ On the compression tab, ensure unicast is selected (click Use My IP - Unicast) not multicast.
✓ If the SLA board is direct connected to a PC through a switch or router, unplug the PC from the
switch or router and connect directly to SLA board (do this hot without restarting either system).
This will determine if the switch or router is the problem. A 100mbps or faster switch is
recommended.
✓ If the above attempts do not fix the problem, try a different PC. Make sure to disable firewalls and
any other network monitoring. Make sure to connected directly to the computer's built-in Network
Interface Card and not through a USB <-> Ethernet adapter or similar.

7

Serial

1. Make sure to use the supplied null modem cable or adapter. Pins 2 and 3 on the DB9 connector can
also be swapped.
2. Navigate to the Control Panel » Device Manager (or use Windows KEY+R to open RUN and enter
devmgmt.msc).
3. Navigate to the COM & LPT ports and expand the menu. Right-click and select Properties.
4. Verify the COM port number and status. The Port Settings (second tab) are preempted by Panel
Plus and do not need to be set here.

 The Windows Mode command from the console can also be used to verify the PC serial port. See the
following Microsoft support article. Use the supplied null modem adapter.
© SightLine Applications, Inc.
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5. Ensure that the serial port is
configured properly in Panel Plus.
Main menu » Configure » Serial
Ports.
6. Protocol should be set to SLA
Protocol and not Passthrough or
similar. Baud should be set to
57600.

7. Make sure TX and RX lines are connected properly. Check the connection on the DB9 connectors,
RX and TX are on pins 2 and 3, respectively.
8. Verify the connection is to one of the RS-232 level serial ports and not the 3.3V serial port found on
many of the adapter boards.

8

Video Not Displayed in Panel Plus

1. Open a Windows command prompt.
2. To find the process that has the 15004 port open type: netstat -a -n -o

3. Ctrl+Alt+Delete » Start Task Manager.
4. From the Windows Task Manager, click on the Process tab.

5. From the main menu » View » Select Columns.
6. Enable PID (Process Identifier).
7. Click OK.
8. Click the new PID column to sort by PID number.

© SightLine Applications, Inc.
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9. Select the PID that has the port open.

10. Click the End Process Button. Relaunch Panel Plus, connect to the device and view the network
video.

9
9.1

Network and Video Diagnostic Checklists
Network

✓ Latest revision of the SLA-1500-AB board.
✓ Check all cable connections to make sure they are making a tight fit.
✓ Replace cables.
✓ Check indicator lights on network switch.
✓ Check indicator lights on 1500-OEM board.
✓ Try a different network port on the switch.
✓ Swap PC and 1500-OEM network ports.
✓ Replace network switch.
✓ Use static IP address on PC and 1500-OEM board. Verify both on same subnet. Verify both have
same network mask.
✓ Verify that there are no IP address conflicts.
✓ Ping the 1500-OEM board from the Command Prompt window.
✓ Disable Windows Firewall.
✓ Use a packet analyzer to examine packets on the network. See Wireshark / Information about
Network Monitor 3.

© SightLine Applications, Inc.
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9.2

Video

✓ Latest revision of the SLA-1500-AB board.
✓ Replace all video cables.
✓ Verify video input and output by connection video source (camera) to video display (analog
monitor).
✓ Try a different video source.
✓ Try a different display. Is the video set to SC NTSC?
✓ Is the video progressive or interleaved?

10 VideoTrack Crash
Panel Plus connects to VideoTrack, the primary SightLine process running on the board. If you are
unable to connect to the board after modifying the firewall rule for Panel Plus, it is possible that
VideoTrack has crashed.
Connecting Panel Plus through serial is an effective way to determine if VideoTrack is running. A serial
port must be configured for command and control (SLA Protocol). This is the factory default
configuration for Serial Port 0.
1. If you cannot connect Panel Plus through serial, establish an SSH session to the board and check
the running processes from the Linux console.
2. Use TeraTerm, PuTTY or another SSH client to connect to the board's IP address. The default port is
22.

3. 1500-OEM: Enter root for both the username and password when prompted.
4. 3000-OEM: When prompted, enter root as the username and leave the password field blank.

© SightLine Applications, Inc.

9

EAN-Troubleshooting-Comms

5. 1500-OEM: to view a list of running processes and look for VideoTrack1500, from the DM-37x#
prompt, enter: ps

6. 3000-OEM: To view a list of running processes and look for VT3000_Release, grom the
root@sla3000:~# prompt, enter: ps

11 Extract the Crash Log
In the event that a 3000-OEM or 1500-OEM experiences a crash, the board automatically writes a log
file (lastCrashLog.txt) to the root home folder (~/).
lastCrashLog.txt contains the kernel log (dmesg), call stack, and the assert line of the crash. The log will
persist in the filesystem and can be retrieved via FTP, SCP, and SSH, etc.
The process of copying files from a 1500-OEM or 3000-OEM to a Windows PC is documented in EANUsing-WinSCP.

© SightLine Applications, Inc.
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12 1500-OEM
12.1 1500-OEM Does Not Boot
Problem: The 1500-OEM startup script was modified and now it does not boot.
Solution: Use single user mode.

 Use Tera Term or PuTTY for this process.
1. Connect PC to Serial Port 0.
2. Use Tera Term or PuTTY to establish an SSH session to the target.
3. Perform a SHIFT+S to get to U-boot.
4. Type: setenv otherbootargs single
5. Type: boot

 This executes a minimal Linux boot. At the command prompt you can now edit rc.local, delete
parameter files, etc.
12.2 PC to 1500-OEM
1. Configure host PC for Static IP Address
(169.254.1.181).
2. Go to Start » Control Panel » Network and
Sharing Center.
3. Change Adapter settings.
4. Right-click on Local Area Connection »
Disable.
5. Right-click on Local Area Connection »
Properties.
6. Select TCP/IPv4. Click Properties.
7. Select Use the following IP address:
•

169.254.1.181

•

255.255.0.0

8. Click OK and then click Close.
9. Right-click on Local Area Connection »
Enable.
© SightLine Applications, Inc.

Figure 2: Configure Host PC for Static IP Address
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12.3 Analog Video on 1500-OEM
1. Verify power to the camera and analog monitor.
2. Connect the camera directly to the analog monitor.
3. From the Multi Camera tab in Panel Plus, verify the camera is connected to Vin0 on the 1500-AB
board.
4. Verify the analog monitor is connected to Vout. Verify Cam0 is set as the input.

5. From the Connect tab in Panel Plus, verify the system is configured for Analog (NTSC) output.

6. In the Acquisition Settings dialog window of Panel Plus, verify Camera Type is configured to NTSC.
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