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Overview

This document outlines the steps for managing the system files using the SightLine upgrade utility
application SLAUpgrade<OEM board><firmware version>. Command line versions of the SightLine
upgrade utilities can also be used that can be managed from a customer GUI implementation (see the
Command Line File Management section).
•

Firmware: The video processing software and support items that are loaded on the OEM video
processor.

•

Parameter File: A file on the video processor which contains all the unit’s non-volatile settings.

•

License File: A file on the video processor (linked to the HW serial number for the device) that
contains the enable application bits for that unit (functions that are enabled).

•

Program Files: Used for getting and placing custom Lua scripts and DLLs.

•

Splash Screen: If the splash JPEG file is present on the unit it will be displayed at startup. It will
continue to display until a SightLine command is received by the unit. Connecting to the unit with
Panel Plus sends the Get Version Number (0x00) message and will disable the splash screen. If the
default camera is not connected, a No Video Source Available message will be displayed instead of
the splash screen.

•

User Logo: SightLine supports placement of a customer logo watermark file on the video for
branding purposes. The file is kept in the unit’s memory.

 If the existing license file is not found on the board for any reason, a new one will be created when
the SightLine application starts for the first time. The new file will be locked and have AppBits
0xFFFF as the default. Contact Sales to reissue the original license file if it was not saved. If the
original file is available use the upgrade utility tool to load it on the board. See the Updating the
License File section.
1.1 Additional Support Documentation
Additional Engineering Application Notes (EANs) can be found on the Documentation page of the
SightLine Applications website.
The Panel Plus User Guide provides a complete overview of settings and dialog windows located in the
Help menu of the Panel Plus application.
The Interface Command and Control (IDD) describes the native communications protocol used by the
SightLine Applications product line. The IDD is also available as a PDF download on the Documentation
page under Software Support Documentation.
1.2 SightLine Software Requirements

 IMPORTANT: The Panel Plus software version should match the firmware version running on the
board. Firmware and Panel Plus software versions are available on the Software Download page.

© SightLine Applications, Inc.
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Upgrade Utility Download and Installation

1. Go to the SightLine software download page and select a version of firmware. Selecting the link will
initiate the download process.
2. Open zip file and right click on the .msi file and select Install. Accept all the defaults for installing
the upgrade utility. Click Close when complete.

 The installer (by default) installs Bin and Firmware folders under C:\Program Files (x86)\SightLine
Applications\SLA-xxxx Upgrade Utility m.nn.rrr. The Bin folder contains the upgrade utility and
library files needed for the utility. The Firmware folder contains all necessary files needed to
upgrade the board.

3

Using the Upgrade Utility

Use the following process to start the upgrade utility and connect to the video processing board.

 IMPORTANT: If there are multiple versions of firmware are on the host PC, open the correct
upgrade utility application that matches the firmware and board.
1. From the Windows Start menu, go to the SightLine application folder and click on the
SLAUpgrade<OEM board><firmware version> utility tool to open it.

Figure 1: SLAUpgrade Utility

 When the application starts for the first time, Windows may prompt a firewall access dialog
window. Select Allow for the update to continue.
2. Click the Find IP Addresses button to get a list of OEM boards on the network. Click on the
appropriate OEM to select it.

3. The upgrade utility application in now ready to use.

© SightLine Applications, Inc.
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Updating the Firmware

 IMPORTANT:
-

-

For version firmware level upgrades, i.e., 2.22.xx to 2.23.xx, it is important to remove the
parameter file from the board (see step 3 below). Older versions of parameter files may not be
compatible with newer versions of firmware.
For sub-version updates, i.e. 2.23.05 to 2.23.09, it is not important to check the Remove the
Parameter File checkbox.
Before removing the parameter, file record the current network, passthrough, and camera
configuration settings, since these settings will be lost once the parameter file is removed from the
board.

Recommended: Save a backup copy of the current license file and parameter file before upgrading the
board (see Retrieving the Parameter File and Retrieving a License File).
1. Start the upgrade utility. Find the boards on the network and highlight the line of the board to
select it.
2. Check the Remove Parameter File box if doing a version firmware level upgrade.
3. Click the Upgrade button.

4. Click Yes in the dialogue box to continue. The application interface will lock until the upgrade is
complete (approximately 1 minute).
5. The Status window displays Upgrade DONE when the process is complete.
6. Click the Find IP Addresses button again to verify that the firmware version number on the OEM
board is now the new version.
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Updating the License File

 IMPORTANT: Before proceeding make sure that all SightLine software applications are closed.
This procedure describes how to retrieve a license file from the OEM board. This is useful when a
license file needs new application bit and to unlock new features on the board. It is common that
SightLine support will ask for customers to retrieve and send a license file from a unit.
Recommended: Save a backup copy of the current license file upon receipt of a board, and before
upgrading the board. A saved license file can save time and expense if repair work is being done.
5.1 Retrieving a License File
1. Start the upgrade utility and select the board.
2. Select File » License File » Get.
3. The Browse for Folder window opens. Choose a directory to put the license file. The Browse
window defaults to C:\Users\<username>\AppData\Roaming\SightLineApplications, but the file can
be put in any PC or network directory with writing permissions.
4. Click OK in the Browse for Folder window. The Status window displays Successfully Received License
File when complete.

5.2 Upload a New License File
After receiving a new license file from SightLine (normally attached to an email), save it to a known PC
or network directory.
1. Start the upgrade utility and select the board.
2. Select File » License File » Put.
3. The Browse for Folder window opens. Navigate to the directory that the new license file is in.
4. Click OK to copy the new license file to the board. The Status window displays Successfully Sent File
when complete.

5. Restart the board to activate the new license file.

© SightLine Applications, Inc.
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5.3 Hardware Serial Number
When contacting Support for OEM board issues it is helpful to provide the serial number. Serial
numbers indicate the OEM board type and the license file being used by the board.
The serial number is printed on a white label attached to the board, e.g., M39741-001-0033.
Figure 2 shows the serial number label locations on the OEM boards.

1500-OEM

3000-OEM

4000-OEM

Figure 2: OEM Board Serial Number Location

5.4 License File Details
Each license file is generated for a specific board and must be loaded on that board. The upgrade utility
will only upload or download a license file that matches the hardware ID of the board. Multiple license
files can be placed in a folder. The upgrade utility will upload the one that matches the board’s
hardware ID.
The name of the license file includes the hardware ID, e.g., 3c943c9448eada74.license.
To license or upgrade a board, download the license file from the board and send it to Support. See
section 7 for instructions to download the license file.
To find the hardware ID, connect to the
unit with Panel Plus and go to the main
menu » Help » About Board. The dialog
will show the hardware ID and related
hardware and firmware information.

 IMPORTANT: Clicking OK will download
the license file and parameter file to
the host PC download directory
(C:\Users\Username\Downloads).
If a license file not matching the hardware
ID is uploaded to the board, this license file
will be ignored.

Figure 3: About the Connected Board

If a board is powered up without a valid
license file, a new locked license file will be
generated automatically. For help
unlocking the file contact Sales.
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Managing the Parameter File

The parameter file on each board contains system and configuration startup settings. See EANParameter File for more information about parameter file settings and how to correctly save them to
the board.
All systems have the following parameter file name: param51ac4a9a. txt. The upgrade utility can be
used to remove, upload, or archive a parameter file from a system for unit recovery.

 IMPORTANT: The upgrade utility can also be used to propagate a known parameter file to multiple
units allowing production teams to quickly duplicate settings across systems. Since all settings are
contained in the parameter file, including network IP addresses, make sure the settings in the file
will not cause a conflict in other systems when propagating files.
6.1 Retrieving a Parameter File
1. Start the upgrade utility and select the board.
2. Select File » Parameter File » Get.
3. The Browse for Folder window opens. Choose a directory to put the parameter file. The Browse
window defaults to C:\Users\<username>\AppData\Roaming\SightLineApplications, but the file can
be put in any known PC or network directory.
4. Click OK in the Browse for Folder window. The Status window displays Successfully Received
Parameter File when complete.

6.2 Upload a Parameter File
1. Start the upgrade utility and select the board.
2. Select File » Parameter File » Put.
3. The Browse for Folder window opens. Navigate to the directory that the new parameter file is in.
4. Click OK to copy the new parameter file to the board. The Status window displays Successfully Sent
Parameter File when complete.

5. Restart the board to activate the parameter file.

© SightLine Applications, Inc.
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6.3 Removing a Parameter File
1. Start the upgrade utility and select the board.
2. Select File » Parameter File » Remove.
3. Click Yes in the dialog window to remove the file. The utility removes the parameter file from the
board and saves a copy in C:\Users\<username>\AppData\Roaming\SightLineApplications.

7

Logo, Splash Screen and Program Files

The upgrade utility can also be used to manage Logo, Splash Screen and Program Files. File types and
definitions are shown in Table 1.
Table 1: Logo, Splash Screen and Program Files
File
User Logo
(watermark)
Splash Screen
Program Files

File Type
userLogo.png
splash.jpg
*.lua,*.so

Explanation
Used for displaying a watermark image in the lower right-hand corner of displayed
imagery.
Used for displaying a splash screen at startup.
Used for custom scripts or custom DLLs.

See the EAN-Overlay-Graphics document for more information on displaying and creating a custom
logo and splash screen.
See EAN-Script Development for more information for working with LUA scripts and DLLs.
7.1 Uploading a File
1. Start the firmware upgrade utility and select the board.
2. Select File » XXX » Put. The Browse for Folder window opens.
3. Navigate to the directory that the new file is in. Click OK to copy the new file to the board. The
Status window displays the result when complete.
4. Restart the board for the change to take effect.
7.2 Retrieving a File
1.
2.
3.
4.

Start the firmware upgrade utility and select the board.
Select File » XXX » Get. The Browse for Folder window opens.
Choose a directory to put the file.
Click OK to copy the file from the board. The Status window displays the result when complete.
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7.3 Removing a File
1. Start the firmware upgrade utility and select the board.
2. Select File » XXX » Remove.
3. The Status window displays the result when complete.

 Program files cannot be removed.
8

Advanced Menu

Get Diagnostic Files: Used to retrieve crash logs and other diagnostic files from the board including
parameter files, license files, etc. that can be useful in troubleshooting. This feature is new in 3.0.xx.
Reset Board (Reboot): Restarts the board.
Set IP Address: Temporarily sets an IP address to the board. This is useful when troubleshooting a
network issue, i.e., the board is on a different subnet. In this case, assign a temporary IP address to the
board so that it can be connected from the Panel Plus application. The temporary address is not saved
(unless it is saved to the parameter file from Panel Plus). The board will revert to the original address
when the board is restarted.
Make Writeable (3000-OEM): This option allows users to use other utilities (WinSCP or FileZilla) to
copy custom program files to the file system or library files of the 3000-OEM board.

 CAUTION: This is an advanced option and could potentially lockup or damage the board. If you
are unsure how to proceed, contact SightLine Support before proceeding.
The filesystem is read-only on the 3000-OEM. To copy files to the 3000-OEM with another utility, the
filesystem must be made temporarily writeable.
1. Start the firmware upgrade utility and select the board.
2. From the main menu » File » Advanced » Make Writeable.

3. After making any changes to the board reset the board. From the main menu » File » Advanced »

Reset Board (reboot).

 Resetting the board ensures that the new files are written to the file system and puts the board
back into a read only state.
© SightLine Applications, Inc.
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Command Line File Management

This section describes how to use command line versions of the SightLine upgrade utilities from a
Windows CMD window or WSL shell to manage system files.
There are two versions of the command line upgrade utility:
•

SLAUpgradeCmd.exe: Runs in a Windows CMD shell. It is distributed in the bin directory of every
firmware distribution.

•

SLAUpgradeCmd: Runs in a shell on a 64-bit Linux system. Ubuntu 18.04 running under WSL is
currently supported. See Installing and Running Linux.

Both programs provide:
-

the same functionality and have the same command line options.

-

support paths using a forward slash (/) as a separator. The Windows CMD version also supports a
backslash (\) as a path separator for paths on the PC host. Do not mix the forward slash (/) and
backslash (\) within a single path.

Examples throughout the document will assume the Windows executable name, and the PC host and a
target system (4000-OEM, 3000-OEM or 1500-OEM) are connected by a network (Figure 3).
4000-OEM, 3000-OEM, or 1500-OEM
Host PC

Ethernet Cable

Network Switch
or Direct connection

WSL or Similar Linux

Figure 4: PC Host and Target System Network

9.1

Command Options

To see the options, run with -?:
SLAUpgradeCmd.exe -IP <IPAddress>[-UP <Firmware Directory>][-DP][-GF
<localDirectory> <remoteName>][-SF <localName> <remoteName>][-GL
<localDirectory>][-SL <localDirectory>]

-IP <IPAddress>

(Required) Indicate the IP Address of the target (e.g., 192.168.1.75).

-UP <Firmware Directory>

Upgrade Firmware. Specify directory containing the upgrade files.

-DP

Delete parameter file during upgrade (recommended). Currently
only works when -UP is used.

-GF <localDirectory> <remoteName>

Get file remoteName and download it to localDirectory.

-SF <localName> <remoteName>

Copy file localName and send it to destination file remoteName.

-GL <localDirectory>

Get License file from SightLine board to localDirectory.

-SL <localDirectory>

Send License file from localDirectory to SLA board.

© SightLine Applications, Inc.
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9.2

Command Line File Management Notes

The firmware upgrade will not be completed if the same revision of firmware is already loaded on the
system.
\bin>SLAUpgradecmd.exe -IP 192.168.1.114 -UP ../firmware/
Update not necessary, already at svnRevision 43635

The firmware upgrade utility does not provide status message if the firmware update procedure
succeeds.
Wildcards are not supported with Get File (GF) option.
Directory names should end in a forward slash (/) or backslash (\):
Good: C:/temp/mySLAdir/
Bad: C:/temp/mySLAdir

Use ./ or .\ to indicate the directory local to the executable.
Remote filenames are assumed to be relative to the SL root directory (/root for 1500, /home/root for
3000, /home/slroot/sl/bin for 4000). For access to remote files outside that directory, SightLine
recommends using scp.
In this example the command downloads the license file and places it in the same directory as
SLAUpgradeCmd.
SLAUpgradeCmd.exe -IP 192.168.1.75 –GL ./

Use quotes around directory and file names when there are spaces in the name:
Good: SLAUpgradeCmd.exe -IP 192.168.1.75 -UP "C:/Program Files (x86)/SightLine
Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/"

Bad:
9.3

SLAUpgradeCmd.exe -IP 192.168.1.75 -UP C:/Program Files (x86)/SightLine
Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/

Command Examples

Upgrade 3000-OEM from installed firmware:
SLAUpgradeCmd.exe -IP 192.168.1.75 -UP "C:/Program Files (x86)/SightLine
Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/"
SLAUpgradeCmd.exe -IP 192.168.1.75 -UP ../firmware/

Upgrade 1500-OEM firmware and remove parameter file during the upgrade:
SLAUpgradeCmd.exe -IP 192.168.1.71 -DP -UP "C:/Program Files
(x86)/SightLine Applications/SLA-3000 Upgrade Utility 2.25.03/firmware/"

Get the parameter file (from board to PC):
SLAUpgradeCmd.exe -IP 192.168.1.75 -GF C:/temp/ ./param51ac9a4a.txt

© SightLine Applications, Inc.
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Set the parameter file (from PC to board):
SLAUpgradeCmd.exe -IP 192.168.1.75 -SF C:/temp/param51ac9a4a_3000.txt
param51ac9a4a.txt

Get the license file (from board to PC):
The license file name depends on the board hardware ID. The upgrade utility determines the correct
file name based on the hardware ID. The filename does not need to be specified, only the path.
SLAUpgradeCmd.exe -IP 192.168.1.75 -GL C:/temp/
SLAUpgradeCmd.exe -IP 192.168.1.75 -GL ./

Set the license file (from PC to board):
The license file name depends on the board hardware ID.
SLAUpgradeCmd.exe -IP 192.168.1.75 -SL C:/temp/

Copy a script file (from PC to the board):
SLAUpgradeCmd.exe -IP 192.168.1.75 -GF "C:/temp/" tracksnap.lua

Copy a watermark logo file from PC to the board:
SLAUpgradeCmd.exe -IP 192.168.1.75 -SF "C:/temp/userLogo.png" userLogo.png

9.4

Upgrade Utility and Command Line Utility

The following table shows the user interface differences between the Upgrade Utility and the
Command Line Utility.
Table 2: Upgrade Utility and Command Line Utility User Interface Differences
Upgrade Utility UI
License File Get and Put
Parameter File Get and Put
Parameter File Remove

Program Files Get and Put
Splash Screen File Get and Put
Splash Screen File Remove

Command Line Utility
Use -GL or -SL option
Use -GF or -SF option
Not yet implemented as
standalone operation.
Can be deleted using the -DF
option when upgrading (-UP).
Use -GF or -SF option
Use -GF or -SF option
Not yet implemented

Upgrade Utility UI
User Logo File Get and Put
User Logo File Remove
Advanced » Reset Board

Command Line Utility
Use -GF or -SF option
Not yet implemented
Not yet implemented

Advanced » Set IP Address Not yet implemented
Advanced » Make Writable Not yet implemented

9.5 Installing and Running Linux
The program is developed using 64-bit Ubuntu 18.04, under WSL. 32-bit Linux is not supported.
Running on native Ubuntu 16.04 has been tested, but the results have been poor with Ubuntu 16.04
running in VirtualBox. Ubuntu 16.04 under WSL has not been tested.
The program and firmware are distributed in a gzip TAR file. Use the following steps to install and run
from the TAR file. This example assumes the target is a 1500-OEM, at address 192.168.1.211, and the
firmware to be loaded is version 2.25.04.

© SightLine Applications, Inc.
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1. Choose a directory to start. In a Linux terminal window create a temporary directory (tmpDir). Copy
the tar file to it, and then cd to it. Type:
mkdir tmpDir
cp ~/Downloads/SLAUpgrade1500_2_25_04.tgz tmpDir
cd tmpDir

2. Unpack the contents of the .tgz file to a local directory tree. Type:
tar -zxvf SLAUpgrade1500_2_25_04.tgz

3. Use the change directory command and type:
cd “SightLine Applications/SLA-1500 Upgrade Utility 2.25.04”

The bin and firmware directories are now in your current directory.
4. Type:
bin/SLAUpgradeCmd -?

A usage message should display.
5. Type:
bin/SLAUpgradeCmd -IP 192.168.1.211 -UP ./firmware/

This will upgrade the target.
9.6 Troubleshooting
Problem

Recommendation

Program does not run.

Try running with -? argument.
Linux version only runs on 64-bit hosts.

Upgrade fails.

Make sure target is up and running on specified IP address.
Use Panel Plus to try to connect to unit.
Make sure host and target are on same network.
Use ping to query the unit.

Target will not run after failed upgrade.

Try power-cycling target.
Follow instructions in EAN-OEM-Recovery for updating firmware
with MicroSD card.

Failed to upgrade <IP Address>.

Check network connection, cables, etc.
Check network adapter is enabled (ifconfig).

Why FTP cannot be used to push files to
the target.

The target file system is Read Only by default. When using the
upgrade utility, the remote file system management is
maintained.

10 Questions and Additional Support
For questions and additional support, please contact Support. Additional support documentation and
Engineering Application Notes (EANs) can be found on the Documentation page of the SightLine
Applications website.
© SightLine Applications, Inc.
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Appendix A - Manually Deleting Files
A1 Using Command Line Programs
Use Tera Term (recommended) or a similar program to establish an SSH session to the target and
delete files. The IP address can be read by connecting to the board through Panel Plus.
1. Establish an SSH session to the target.
2. Login:
1500-OEM: Username and password - root.
3000-OEM: Username - root (no password).
4000-OEM: Username and password - slroot.

 The 1500-OEM and 4000-OEM file system have been created with read/write permissions. The
3000-OEM has a read only file system.
3. To make it writable, type:
mount -w -o remount /

4. To see all the files, type:
ls

5. To remove a file, use:
rm drawCircle.lua
sync

Figure A1: Manually Deleting Files with Tera Term

6. If connecting to the 3000-OEM, power cycle the target hardware or type reboot to restart the
system. When the system reboots the file system will automatically return to read only mode.
A2 Using SightLine Upgrade Utility and FTP Client
1. Open a 1500, 3000, or 4000 Upgrade Utility application.
2. Click the Find IP Addresses button to see SLA hardware on the network.
3. Select the target hardware.

4. The 1500-OEM and 4000-OEM file system has been created with read/write permissions. The 3000OEM has a read only file system. To make it writable, got to the main menu » File » Advanced »
Make Writable.

© SightLine Applications, Inc.
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5. Open an FTP client such as FileZilla. Connect to the target hardware IP address:
1500-OEM: Username and password - root.
3000-OEM: Username - root (no password).
4000-OEM: Username and password - slroot.

6. If connecting to the 1500-OEM navigate to the /root directory. If connecting to the 3000-OEM
navigate to /home/root. If connecting to the 4000-OEM navigate to /home/slroot/sl/bin.

7. Right-click on the file and select Delete.

 If connecting to the 3000-OEM, power cycle
the target hardware or type
reboot

to restart the system. When the system
reboots the file system will automatically
return to read only mode.

© SightLine Applications, Inc.
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Appendix B - SLA-HDMI-SDI Microcontroller Program Update (4000-OEM Only)
The SLA-HDMI-SDI adapter board is supported in 3.3.x software. In 4000-OEM applications, in some
cases, it may be necessary to update the microcontroller program running on the board.

 See the SLA-HDMI-SDI section in the ICD-3000-4000 Adapter Boards for technical specifications.
The SLA-HDMI-SDI serial port on connector J2 is at 3.3V TTL levels. When connecting to the 4000-OEM
board, use CAB-0301 cable to connect to an unused serial port on the OEM (typically Serial Port 1 or
Serial Port 3).

 See the Serial Port Summary section in the ICD-4000-OEM for serial port selection.
Requirements:
•
•
•

•
•
•

40000-OEM board.
SLA-HDMI-SDI with power.
SLA-CAB-0301 connected from the SLA-HDMI-SDI serial port to an unused serial port on the 4000OEM board.
Firmware version 3.3.x or higher.
Tera Term (recommended) or PuTTY SSH terminal.
Boards must be powered and have a network connection for SSH.

 CAUTION: To prevent damage to hardware boards, verify that the SLA-CAB-0301 is connected to the correct serial
port used in this procedure.

Programming:
Use Tera Term (recommended) or PuTTY terminal emulator program to upgrade the SLA-HDMI-SDI
board. This process will take approximately two minutes to complete.

 This example uses Serial Port 3 on the 4000-OEM to connect to the serial port on SLA-HDMI-SDI
board.
1. Establish an SSH session to the target. The IP address can be read by connecting to board through
Panel Plus.
2. Login using the default username and password: slroot
3. Change the directory to: sl/bin
4. Type in the name of the program with the correct <port> and <hex file> names and run the
application.
x_HdmiToHdsdi_Loader_ARM64_Release.out <port> <hex file>

 CAUTION:

To prevent damage to the hardware boards it is important to use the same serial port number in this
step that was used to connect to the SLA-HDMI-SDI board.

© SightLine Applications, Inc.
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5. When the program progress is finished (~15 seconds) Successfully loaded program is displayed in
the terminal window.

 If an error message displays, verify that SLA-CAB-0301 is securely connected and the serial port
number is correct when running the x_HdmiToHdsdi_Loader_ARM_Release.out application.
6. Confirm the program was loaded and working correctly. In the terminal window type:
sudo get-edid -b 4 | parse-edid

7. In the terminal window verify Identifier “SLA-HDSDI” is displayed in the terminal window.
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