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Troubleshooting Comms Overview

This document reviews frequent network questions and common system connection problems.
Problem

Possible Cause

Solution

No network
connection

IP address conflicts
Subnet mismatch

Verify that there are no IP address conflicts.
Verify subnet mask match IP class
Firewall or router settings

Bad physical connections

Check physical connections (Link lights, etc)

Incompatible display

Try a known working input source (camera or DVD player) connected directly to
verify the display is working.

No video source

Verify the camera (or other source) is functioning by connecting it directly into the
display.

No power to SightLine
hardware

Verify correct voltage (5V or 12V depending on unit)
Look for status lights on the board (non-enclosure units)

Wrong input source
Selected

Use Panel Plus to set the camera order.

Analog, HD-SDI, or HDMI
video output disabled

System was configured for network output only. Use Panel Plus to enable the Analog,
HD-SDI, or HDMI video output.

Incorrect delivery
method for sending out
a network stream

On the Compression tab, ensure Unicast is selected (click Use My IP - Unicast) not
Multicast.

Wrong serial port

Try selecting a different Com Port from Panel Plus.

TX and RX are swapped

Try using a null modem in line with your cable to the SightLine hardware.

Bad serial port

Try hooking your serial port up to another device like a PC and send commands.

Wrong voltage level

Verify with the ICD for your product. Some OEM boards assume a 3.3V TTL serial
communication.

Incorrect or no ground

Verify your serial cable is using the same digital ground as the SightLine hardware.

Incorrectly configured
serial ports

Connect via Network and configure with: Panel Plus main menu » Configure »Serial
Ports. Verify baud rate and other settings.

IP address / network
mask mismatch

If a DHCP server is not available, the default IP address for SightLine hardware is
169.254.1.180 (1500-OEM) or 169.254.1.181 (3000-OEM) or 169.254.1.182 (4000OEM) with a subnet mask of 255.255.0.0.
Set PC to be on the same subnet, and then use Panel Plus to change the network
settings of the SightLine hardware.
Clear the ARP table from the command line (arp -d *).

Windows Firewall

Disable windows firewall.

Router/switch issues

Try using a simple (unmanaged) network switch.

Not connected

Select the unit name from the pull-down list and click Connect.
The IP address, temperature, and firmware version should be visible in the status bar.

Wrong network adapter

Disable all Wireless and other network interfaces except the wired (LAN).

Bad parameter file

Remove parameter file with Upgrade Utility. See Removing the Parameter File

Unit firmware crash

Remove and restore power to the unit. See VideoTrack Crash.

Configuration problems

Verify correct network streaming settings
Verify network hardware
Review decoder settings such as buffering

No video output /
video is black,
etc.

Serial port is not
working

Unit does not
respond to
command but is
shown on the
network

Stalling/stuttering
network video
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Serial

1. Verify that power and ground are supplied
to the correct pins. See Figure 1 example.

 See the corresponding OEM ICD for
power connections.
2. Verify that screw terminals on top of
connector are tight.
3. Verify that connector is seated firmly within
the socket on the hardware.
Figure 1: Example 3000-IO Power and Serial Connector

3

Ethernet

1. Verify all cables are in good condition and firmly connected (swap cables if necessary).
2. Verify power is supplied to all hardware, network switch, PC, video processor, etc.
3. Verify that the link lights are active for the port on the network switch where the video processor is
plugged in.

 A network switch is recommended for bench testing rather than direct connection with a PC. If
the SightLine hardware is directly connected to the PC and a DHCP server is used, the PC can
lose the network connection if the SightLine hardware is disconnected or power cycled. It can
take up to three minutes for the PC to reestablish connection, which can cause a timeout of the
DHCP server. This can be avoided by setting the PC and the SightLine hardware to a static IP
address.
4. Verify that the DHCP server can provide an IP Address.
5. If a DHCP server is not used, the video processor will default to the following IP addresses:
•

1500-OEM: 169.254.1.180 subnet mask 255.255.0.0

•

3000-OEM: 169.254.1.181 subnet mask 255.255.0.0

•

4000-OEM: 169.254.1.182 subnet mask 255.255.0.0

 Verify that the IP address and subnet mask are valid for your network. For most networks, and IP
address of 192.168.1.x and 255.255.255.0 is the correct subnet mask. For IP addresses in the
range 169.254.x.x, 255.255.0.0 is correct.
6. Open a Command Prompt window and use the IPCONFIG command to see the network
configuration of the PC. See the following Microsoft support article.
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7. Verify that the PC and video processor are on the same subnet and using the same subnet mask.

 If there is a subnet mask mismatch between the host PC and the SightLine hardware, Panel Plus
will report this problem when connecting to the SightLine hardware. Panel Plus uses a broadcast
message (255.255.255.255) to query the network for SightLine units. This allows for discovery
and response across separate networks. Panel Plus will still discover the hardware and will
display a warning about the hardware not being on the same network.
8. Ping the SightLine board from the PC.

 Ping may be successful even when Panel Plus is using the wrong network interface.

9. Clear the ARP cache on the PC, type: arp -d *
10. Download and install a network packet analyzer to verify that the video processor is generating
packets.
References: Wireshark / Information about Network Monitor 3
11. Disable Windows Defender or Microsoft Firewall protection. See the following Microsoft support
article.
12. Disable all unused wired and wireless network
interfaces. See Microsoft Windows support for
more help information.

 Multiple network interfaces on a PC can
confuse Panel Plus or the upgrade server.

 Leave the Wired network enabled.
13. Verify the wired network interface is enabled
and connected.

Figure 2: Disable WiFi Network Interface Example
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Windows Firewall

Windows firewall can block Panel Plus from accessing the network. The workaround is to modify the
firewall rule that is created when the application is launched for the first time. Windows firewall
manages network access on a per-application basis - a firewall rule is created for each installed version
of Panel Plus.
1. Press Windows KEY+R to open a Run prompt. Enter firewall.cpl.

2. From the sidebar select Allow an app or feature through Windows Defender Firewall.

3. Select Change settings and approve the subsequent user account control prompt.
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4. Check the public and private boxes for each slapanelplus entry.

5. Click OK and close.

5

Removing the Parameter File

If there are no problems with the firewall settings, remove the parameter file using the SightLine OEM
upgrade Utility. This should allow a connection to the unit with Panel Plus.
See EAN-Firmware Upgrade Utility for additional parameter file management information.
1. From the Start menu on your PC, go to SightLine Applications and open the appropriate upgrade
utility application.
2. Click the Find IP Addresses button.
3. Select the IP address of the board.
4. From the main menu, go to File » Parameter File » Remove.

 Use the Get function to download a copy of the existing parameter file. This can be used in
future diagnostics if problems continue.
5. Click Yes in the dialog window to remove the file. The utility removes the parameter file from the
board and saves a copy in C:\Users\<username>\AppData\Roaming\SightLineApplications.
6. Close the Upgrade Utility and cycle the board power.
7. In Panel Plus, wait for the system to boot, and then try connecting to the board.
© SightLine Applications, Inc.
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Stuttering / Stalling Network Video

The problem may be that something is causing packet loss, or possibly multiple streams arriving at the
same UDP port on the host PC.
✓ Verify that analog video output is working correctly if possible.
✓ Ensure that there are no other video streams going to the PC (such as from another SightLine board
or some other device). Multiple streams arriving at the same UDP port on the PC can cause packet
loss.
✓ If the video processor is direct connected to a PC through a switch or router, unplug the PC from
the switch or router and connect directly to the SightLine board (this can be done without
restarting either system). This will determine if the switch or router is the problem. A 100Mbps or
faster switch is recommended.
✓ If the above attempts do not fix the problem, try a different PC. Disable firewalls and any other
network monitoring. Connect directly to the computer's built-in Network Interface Card and not
through a USB <-> Ethernet adapter or similar.

7

Serial

7.1 Verify Physical Connections
Verify that the PC serial port is working by connecting to another known device.
Use the supplied null modem cable or adapter. Pins 2 and 3 on the DB9 connector can also be
swapped.
Verify the connection is to one of the RS-232 level serial ports and not the 3.3V TTL serial port found on
many of the adapter boards. Additionally, you can also try replacing the USB to RS-232 adapters.
7.2 Verify Windows COM PORT Status
1. Navigate to Control Panel » Device Manager or use Windows key +R to open RUN and enter
devmgmt.msc.
2. Navigate to the COM & LPT ports and expand the menu. Click on the USB-to-Serial Comm Port.
Right-click and select Properties.
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6

EAN-Troubleshooting-Comms

3. Verify the COM port number and status. The Port Settings (second tab) are preempted by Panel
Plus and do not need to be set here.

 The Windows Mode command from the console can also be used to verify the PC serial port. See the
following Microsoft support article. Use the supplied null modem adapter.
7.3

Verify SightLine Serial Port Configuration

1. Ensure that the serial port is configured properly in Panel Plus. Main menu » Configure » Serial
Ports.
2. Protocol should be set to SLA Protocol.
3. Baud should be set to 57600.

Figure 3: Verify Serial Port Configuration
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Video Not Displayed in Panel Plus

1. Open a Windows command prompt.
2. To find the process that has the 15004 port open, type: netstat -a -n -o

 This will list the protocol (UDP), Local IP and Port number (15004), Client address, and the
Process ID (PID) of the software using that port.
3. Ctrl+Alt+Delete » Start Task Manager.
4. From the Windows Task Manager, click on the Process tab.

5. From the main menu » View » Select Columns.
6. Enable PID (Process Identifier).
7. Click OK.
8. Click the new PID column to sort by PID number.
9. Select the PID that has the port open.

10. Click the End Process Button. Relaunch Panel Plus, connect to the device and view the network
video.

© SightLine Applications, Inc.
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Network and Video Diagnostic Checklists

9.1

Network

✓ Latest revision of SightLine hardware.
✓ Check all cable connections to ensure a tight fit.
✓ Replace cables.
✓ Check indicator lights on network switch.
✓ Check indicator lights on OEM board.
✓ Try a different network port on the switch.
✓ Swap PC and OEM network ports.
✓ Replace network switch.
✓ Use static IP address on PC and SightLine hardware.
▪

Verify both on same subnet.

▪

Verify both have same network mask.

✓ Verify that there are no IP address conflicts.
✓ Ping the SightLine hardware from the Command Prompt window.
✓ Disable Windows Firewall.
✓ Use a packet analyzer to examine packets on the network. See Wireshark / Information about
Network Monitor 3.
9.2

Video

✓ Latest revision of SightLine hardware.
✓ Replace all video cables.
✓ Verify video input and output by connection video source (camera) to video display (monitor).
✓ Try a different video source.
✓ Try a different display. Is the video set to NTSC or PAL?
✓ Is the video progressive or interleaved?

10 Syslog 4000-OEM
By default, output from the video processing software, VideoTrack, is saved to /var/log/user.log using
the Linux syslog facility. Each line of VideoTrack output will be preceded by a date/time stamp and the
word VTNext.

 Reviewing this file for errors or warnings can help with troubleshooting the system.
By default, if VideoTrack exits, the output from Linux utility dmesg will also be saved to
/var/log/user.log, with each line preceded by dmesg. This may also provide some clues as to why
VideoTrack exited.
© SightLine Applications, Inc.
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11 Syslog 1500-OEM
Due to potential performance issues with the file system VideoTrack output is not saved by syslog by
default.
By default, the script /root/vt_start.sh does not exist on the 1500-OEM. To save the VideoTrack output
with syslog, VideoTrack1500 must be launched using the script /root/vt_start.sh. VideoTrack1500 is
normally started with the script /etc/rc.d/rc.local. But, if the /root/vt_start.sh script exists, it will run
that instead.
To create and run the vt_start.sh script, copy /root/vt_start_Default.sh to /root/vt_start.sh to enable
saving VideoTrack output to /var/log/user.log.
Alternatively, copy /root/vt_start_MicroSD.sh to vt_start.sh to save VideoTrack output to the microSD
card at /mnt/mmcblk01/log/user.log.
With either script, each line of VideoTrack output will be preceded by a date/time stamp and the word
VideoTrack1500. If VideoTrack exits, the output from Linux utility dmesg will be saved to the log file,
with each line preceded by dmesg. This may provide some clues as to why VideoTrack exited.

12 VideoTrack Crash
Panel Plus connects to VideoTrack, the primary SightLine process running on the board. If you are
unable to connect to the board after modifying the firewall rule for Panel Plus but are still able to
discover it on the network, it is possible that VideoTrack has crashed.
Connecting Panel Plus through serial is an
effective way to determine if VideoTrack is
running. A serial port must be configured for
command and control (SLA Protocol). This is
the factory default configuration for Serial Port
0.
1. If you cannot connect Panel Plus through
serial, establish an SSH session to the board
and check the running processes from the
Linux console.
2. Use Tera Term (recommended) or another
SSH client to connect to the board IP
address. The default port is 22.

Figure 4: Verity Video Track - Tera Term

3. Log into the board:
•

1500-OEM: Enter root for both the username and password when prompted.

•

3000-OEM: When prompted, enter root as the username and leave the password field blank.

•

4000-OEM: Enter slroot for both the username and password when prompted.

4. To view a list of running processes and determine if VideoTrack is running, from the command
prompt, enter: ps. An example of VideTrack running is shown in Figure 5.
© SightLine Applications, Inc.
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Example - 1500-OEM
VideoTrack

Example - 3000-OEM
VideoTrack

Figure 5: Example - Process Lists Running on 1500-OEM / 3000-OEM

13 Extract the Crash Log
If SightLine software experiences a crash, the board automatically writes a log file (lastCrashLog.txt) to
the root home folder (~/).
lastCrashLog.txt contains the kernel log (dmesg), call stack, and the assert line of the crash. The log will
persist in the filesystem and can be retrieved via FTP, SCP, etc. Once the file has been removed, delete
the file to ensure that the next log file corresponds to the test being performed.

 On the 3000-OEM, the file system must be made writable to delete the file.
The process of copying files from SightLine hardware to a Windows PC is documented in EAN-UsingWinSCP.

14 Trouble Shooting Command and Control
1. Open Panel Plus and connect to the OEM hardware.
2. Panel Plus main menu » File » Net Trace.
3. Check the Trace Commands checkbox.

Figure 6: Enable Network Debug Trace

The SetSDRecordingParameters (0x1E) command sets the record mode to enable network debug trace of
commands and responses (0x03).
Example: 51,AC,0B,1E,03,00,00,00,00,00,00,00,00,C7
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